Renewed Vision Store

Support Alerts

Apple OS 10.7 - Lion Released

ProPresenter 4:   Fully compatible with Mac OS 10.7 (Lion). Be sure you're using the latest version.

ProPresenter 3:   May work with Mac OS 10.7 (Lion), but it's not officially tested or supported. Please stay with Snow Leopard or lower for this version of ProPresenter.

ProVideoPlayer (PVP):   We're testing a version of the application that is Lion compatible and will hopefully release that soon. So please stay with Snow Leopard or lower for now and stay tuned to the site for the update.

ProPresenter SDI Module

Mac LogoThe ProPresenter 5 SDI Module converts all standard ProPresenter output to a native SDI signal and sends this image out whatever SDI card is installed in the Mac. It's a MAC ONLY module for ProPresenter (not available for Windows). For more information see the product page.


SDI Module for ProPresenter 5 (Mac only)
AlertNOTE: Each Module purchased can be used on ONE machine only and is keyed to that system. If you move to a new machine, it must be removed from that system and re-keyed to another.
Add ProPresenter SDI Module (Mac only) $99


NOTE: Although not recommended, support for HD1080 resolution requires a suitable Black Magic card (Extreme Decklink HD) as well as a display connected that has this resolution selected in the Apple Displays control panel. Neither DVD nor web content can be displayed through the SDI Module (due to DRM legal issues). Firewire output is not supported. Modules are valid for just one computer and are non-transferrable unless switching to a new machine. A ProPresenter license is required to use any module.


SDI Module for ProPresenter 4 (only)
AlertNOTE: This module is different in ProPresenter 4 as it's combined with several other advanced capabilites. The only way to enable this on ProPresenter 4 is to buy our previous Advanced Module. Click on the link below to take you to this screen.

Purchase SDI output capability for ProPresenter 4




SUBTOTAL $